Search found 27 matches

Go to advanced search

by jlucben
Sat Oct 29, 2016 6:55 pm
Forum: General Discussion
Topic: Load user settings not working in UWP
Replies: 5
Views: 3400

Re: Load user settings not working in UWP

Hello after some tries : This code is working string filenewpath = folder.Path + "/" + nomsave; Resultat.Text = filenewpath; var xdoc = XElement.Load(filenewpath).Element("UserSettings"); botUser.Settings.Load(xdoc); Resultat.Text = botUser.Settings["Name"].Value; And this one isn't working string f...
by jlucben
Fri Oct 28, 2016 8:42 pm
Forum: General Discussion
Topic: Load user settings not working in UWP
Replies: 5
Views: 3400

Re: Load user settings not working in UWP

Hello When I display in resultat.text var xdoc =XDocument.Load(filenewpath); Resultat.Text = xdoc.FirstNode.ToString(); <Siml> <UserSettings> <Variable Name="Name" Value="Jean luc" /> <Variable Name="Test" Value="Test Chargement" /> </UserSettings> </Siml> But after : Resultat.Text = botUser.Setting...
by jlucben
Fri Oct 28, 2016 7:34 pm
Forum: General Discussion
Topic: Load user settings not working in UWP
Replies: 5
Views: 3400

Re: Load user settings not working in UWP

I Try also

string filenewpath = folder.Path + "/" + nomsave;
XDocument.Load(filenewpath);

the value of filenewpath is OK
but the result is the same - not correct

regards
by jlucben
Fri Oct 28, 2016 6:59 pm
Forum: General Discussion
Topic: Load user settings not working in UWP
Replies: 5
Views: 3400

Load user settings not working in UWP

Hi I save user settings as is : var file = await folder.CreateFileAsync(nomsave , CreationCollisionOption.ReplaceExisting); var stream = await file.OpenAsync(FileAccessMode.ReadWrite); userSettingsDoc.Save(stream.AsStreamForWrite()); stream.Dispose(); Where folder = ApplicationData.Current.LocalFold...
by jlucben
Sun Oct 23, 2016 7:24 pm
Forum: General Discussion
Topic: HOW is Working the Random Responses Settings In Syn Bot Stud
Replies: 2
Views: 2420

Re: HOW is Working the Random Responses Settings In Syn Bot

Hi All is working fine with the code below but documentation is very unclear ....

<Concept Name="Introduction">

<Model>
<Pattern>HELLO ASSISTANT</Pattern>
<Response>
<Random Get="Greet"></Random>
</Response>
</Model>

</Concept>
by jlucben
Sun Oct 23, 2016 6:07 pm
Forum: General Discussion
Topic: HOW is Working the Random Responses Settings In Syn Bot Stud
Replies: 2
Views: 2420

HOW is Working the Random Responses Settings In Syn Bot Stud

Hi In Random Responses Settings I define <Random Name="Greet"> <Item>Hi there!</Item> <Item>Well, hello there!</Item> <Item>Hi</Item> <Item>Long time no see</Item> <Item>Hey</Item> <Item>What's up</Item> <Item>How are you today?</Item> </Random> In my Bot : <Concept Name="Introduction"> <Model> <Pat...
by jlucben
Fri Oct 21, 2016 5:45 pm
Forum: Feature Request and Suggestions
Topic: Nested sets
Replies: 1
Views: 2090

Nested sets

Some suggestions To improve Siml :

Nested sets - ability To référence an existant set in a set définition - today not working
Ability To include in a set définition a null item .

Regards

Go to advanced search