AhmedMuneer
Posts: 2
Joined: Wed Sep 22, 2021 4:17 pm

An issue with the latest Syn Oryzer Studio 3.5

Wed Sep 22, 2021 4:51 pm

Image
Hi, I found out about Oryzer Studio from this tutorial link https://www.codeproject.com/Articles/52 ... harp-using

Apparently, he is using an older version of Oryzer Studio which for some reason no where to be found from the internet. I followed his tutorial step-by-step several times but when I try the bot using Oscova Test Panel it always doesn't show $sys.user.table-date value for me. When I tried to use his ".west" file in Visual Studio it works perfectly using The Nuget package "Syn.Bot". But mine which created using "Oryzer Studio 3.5", it doesn't move to the next respond in Visual Studio !!

I confirmed this by downloading his ".west" file and modifying one little thing in it using "Oryzer Studio 3.5" and the problems appears again in Visual Studio 2019 as well as in Oscova Test Panel. Please, if someone can give me a link where I can get to download older versions of Oryzer Studio, I'll be really really glad.

best regards

User avatar
Leslie
Lead Software Architect
Posts: 378
Joined: Fri Sep 14, 2012 12:20 pm
Contact: Website

Re: An issue with the latest Syn Oryzer Studio 3.5

Wed Sep 22, 2021 10:30 pm

Try to use $user.table-date, I believe the latest version removed the requirement of prefixing User and Bot variables with Sys.

AhmedMuneer
Posts: 2
Joined: Wed Sep 22, 2021 4:17 pm

Re: An issue with the latest Syn Oryzer Studio 3.5

Thu Sep 23, 2021 10:44 am

Ok, I just did that but nothing changed. Same problem after saving the file, training the bot and testing on Oscova Test Panel. By the way, The issue is only happening with those two variables $sys.user.table-date and $sys.user.table-num ,
look at https://www.codeproject.com/Articles/52 ... harp-using

But $sys.number for number of people selected and mobile number is shown on response text.
Image
Its frustrating, I don't know why they didn't put previous versions there just in case the latest one didn't do well.

Return to “Report Bugs and Issues”

Who is online

Users browsing this forum: No registered users and 1 guest