allen_n
Newbie
Posts: 4
Joined: Mon Jan 23, 2017 6:04 pm

Can't install Syn.Speech for a Windows 8.1 app.

Sat Jan 28, 2017 6:48 am

I want to incorporate speech recognition into a Windows Runtime app (for Windows 8.1), but it's not compatible:

"Could not install package 'Syn.Speech 1.0.3'. You are trying to install this package into a project that targets 'Windows,Version=v8.1', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author."

Is there a package that I can use for this target?

User avatar
Fantom
Help & Support
Posts: 320
Joined: Fri Oct 25, 2013 9:20 pm

Re: Can't install Syn.Speech for a Windows 8.1 app.

Sat Jan 28, 2017 4:52 pm

The short answer would be - no the library isn't compatible with Win Store apps. The library is built on top of .NET 4.5 and migrating it to a portable class library seems difficult due to the lack of APIs in other platforms. We are considering to tailor down the ASR engine to bare minimum to support other platforms but there is no ETA on when those commits will be made.

The only option for now in my opinion would be to create an online API of some sort.

allen_n
Newbie
Posts: 4
Joined: Mon Jan 23, 2017 6:04 pm

Re: Can't install Syn.Speech for a Windows 8.1 app.

Sun Jan 29, 2017 6:47 am

Thanks, Franz. I guess I'll try the online route.

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest