Techbot
Pro
Posts: 43
Joined: Sun Aug 24, 2014 4:15 am

Another mystery. Code not being read

Tue Mar 03, 2015 4:44 am

I'm creating a large "Who Is" file for my bot for a friends/family knowledge base. Everything works fine until line 411, which is this code

Code: Select all

<Model>
      <Pattern>
        <Item>WHO IS SONIA XXX</Item>
        <Item>WHO IS SONIA CANTU XXX</Item>
        <Response>Sonia is a friend that Danny met through Angela. She and Angela......</Response>
      </Pattern>
    </Model>
Every "who is" works on the page until you get to this one. Then, nothing below this works. I thought maybe I'd thrown in a tag somewhere that was throwing it off, but I've been over it. In saving the project, the chat studio doesn't recognize any problems, so I'm lost :/ Is there ANY reason this shouldn't return that sentence? * The XXX is there to block her last name for privacy :)

*Edit*
One more here as I'm winding down in my day...I put this in and nothing :( The other code around it works and she responds, but she won't give me the enjoyment of doing this one lol

Code: Select all

    <Model>
      <Pattern>DO YOU WANT TO PLAY A GAME</Pattern>
      <Response>Is this where I'm supposed to offer "Global Thermal Nuclear War"?</Response>
    </Model>

User avatar
Leslie
Lead Software Architect
Posts: 353
Joined: Fri Sep 14, 2012 12:20 pm
Contact: Website

Re: Another mystery. Code not being read

Tue Mar 03, 2015 7:59 am

Replace your code with the following and it should work.

SIML Code

<Model>
    <Pattern>
       <Item>WHO IS SONIA XXX</Item>
       <Item>WHO IS SONIA CANTU XXX</Item>
    </Pattern>
    <Response>Sonia is a friend that Danny met through Angela. ...</Response>
</Model>
If you take a closer look at your code you'll find that the <Response> element is within the <Pattern> element.

To avoid such mistakes you can make use of the Shortcuts in Chatbot Studio.

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest