thesheps
Posts: 2
Joined: Sun Nov 08, 2020 1:45 pm

Problem using OSCOVA in Unity WebGL Project

Sun Nov 08, 2020 1:52 pm

Hey folks!

First off - great product, love your work!

I've completely hit a brick wall here and not sure what to do :(

I'm using the unitypackage you folks have kindly provided, and my project plays cleanly when targeting Desktop, and indeed everything looks completely fine when playing my scene manually in the editor, but the minute I try and BuildAndRun it, targetting WebGL, I get the following errors in the console and nothing works:

Code: Select all

System.TypeInitializationException: The type initializer for 'Syn.Bot.Oscova.OscovaBot' threw an exception. ---> System.TypeInitializationException: The type initializer for '.' threw an exception. ---> System.ArgumentNullException: Value cannot be null.
Parameter name: input
  at System.IO.BinaryReader..ctor (System.IO.Stream input, System.Text.Encoding encoding, System.Boolean leaveOpen) [0x00000] in <00000000000000000000000000000000>:0 
   --- End of inner exception stack trace ---

   --- End of inner exception stack trace ---
   
I've stripped everything right back in my scene, such that my MonoBehaviour now just has a single line of code in the Start script:

CSharp Code

        private void Start()
        {
            try
            {
                _mainBot = new OscovaBot();
            }
            catch (Exception ex)
            {
                Debug.LogError(ex);
            }
        }

No idea how to go about diagnosing this!! Is there anything that I might have missed? Happy to talk this through on gitter!!

thesheps
Posts: 2
Joined: Sun Nov 08, 2020 1:45 pm

Re: Problem using OSCOVA in Unity WebGL Project

Sun Nov 08, 2020 2:01 pm

Turns out I was just using an old version of the package :D Everything now works fine. Thanks folks :)

Return to “Report Bugs and Issues”

Who is online

Users browsing this forum: No registered users and 1 guest