dotlogics434
Posts: 3
Joined: Thu Jan 16, 2020 3:39 pm

Problem installing Windows Service for OSCOVA bot WEBAPI Channel

Thu Feb 27, 2020 4:04 pm

I am trying to build a windows service that starts and stops the Oscova bot WEBAPIChannel automatically. I have build the service but there is a problem installing the service. The error log says.


Microsoft (R) .NET Framework Installation utility Version 4.8.3761.0
Copyright (C) Microsoft Corporation. All rights reserved.


Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the D:\IntallService\Service\SIMLWinServices.exe assembly's progress.
The file is located at D:\IntallService\Service\SIMLWinServices.InstallLog.
Installing assembly 'D:\IntallService\Service\SIMLWinServices.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\IntallService\Service\SIMLWinServices.exe
logfile = D:\IntallService\Service\SIMLWinServices.InstallLog
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.InvalidOperationException: Cannot open Service Control Manager on computer '.'. This operation might require other privileges.
The inner exception System.ComponentModel.Win32Exception was thrown with the following error message: Access is denied.

The Rollback phase of the installation is beginning.
See the contents of the log file for the D:\IntallService\Service\SIMLWinServices.exe assembly's progress.
The file is located at D:\IntallService\Service\SIMLWinServices.InstallLog.
Rolling back assembly 'D:\IntallService\Service\SIMLWinServices.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\IntallService\Service\SIMLWinServices.exe
logfile = D:\IntallService\Service\SIMLWinServices.InstallLog
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

User avatar
Leslie
Lead Software Architect
Posts: 375
Joined: Fri Sep 14, 2012 12:20 pm
Contact: Website

Re: Problem installing Windows Service for OSCOVA bot WEBAPI Channel

Thu Feb 27, 2020 4:40 pm

Although I have rarely worked with Windows Services the error clearly states that elevated privilege is required to work with the service you are trying to enable.

Maybe you should launch the app or CMD in Administrative Mode.

dotlogics434
Posts: 3
Joined: Thu Jan 16, 2020 3:39 pm

Re: Problem installing Windows Service for OSCOVA bot WEBAPI Channel

Thu Feb 27, 2020 4:59 pm

I have tried command prompt with elevated privileges, the error log persists with the same output. Someone please reproduce it on your own end and try to elaborate what is the required solution.

User avatar
Leslie
Lead Software Architect
Posts: 375
Joined: Fri Sep 14, 2012 12:20 pm
Contact: Website

Re: Problem installing Windows Service for OSCOVA bot WEBAPI Channel

Sun Mar 01, 2020 2:30 pm

Our team can only reproduce this if you submit a link to the source-code of your project. We've worked with WebAPIs and on our machines the programs usually ran without any issues.

Return to “Report Bugs and Issues”

Who is online

Users browsing this forum: No registered users and 1 guest